diff --git a/gui-wm/swayfx/Manifest b/gui-wm/swayfx/Manifest
new file mode 100644
index 0000000..af1070e
--- /dev/null
+++ b/gui-wm/swayfx/Manifest
@@ -0,0 +1 @@
+DIST swayfx-0.3.2.tar.gz 5684837 BLAKE2B ffe2a5d4a756f30007fb65824471196b6c51034a4e205558a82f547211714be8b0ae03763f32203c9d99fab4d3d69320f2244975a7c279d813091b8629d0c20a SHA512 0cffa25fc4b4d40621b14d9dc430f1aa9956ad935124cfda7dd1a63cbf997f0d506922b1168c7ad13250fa909cc1328526818f75ec936aa8d6cc40152dfbb358
diff --git a/gui-wm/swayfx/metadata.xml b/gui-wm/swayfx/metadata.xml
new file mode 100644
index 0000000..c28dc08
--- /dev/null
+++ b/gui-wm/swayfx/metadata.xml
@@ -0,0 +1,36 @@
+
+
+
+
+ siina@criminallycute.fi
+ Siina Mashek
+
+
+ "SirCmpwn's Wayland window manager" is an i3-compatible window manager
+ for Wayland.
+
+ sway was created to fill the need of an i3-like window manager for
+ Wayland. The upstream i3 developers have no intention of porting i3 to
+ Wayland, and projects proposed by others ended up as vaporware. Many
+ thanks to the i3 folks for providing such a great piece of software, so
+ good that your users would rather write an entirely new window manager
+ from scratch that behaved *exactly* like i3 rather than switch to
+ something else. Swayfx is a fork intending to bring more effects to sway.
+
+
+
+ WillPower3309/swayfx
+
+ William McKinnon
+
+ https://github.com/WillPower3309/swayfx/issues
+ https://github.com/WillPower3309/swayfx/releases
+
+
diff --git a/gui-wm/swayfx/swayfx-0.3.2.ebuild b/gui-wm/swayfx/swayfx-0.3.2.ebuild
new file mode 100644
index 0000000..aecc9fe
--- /dev/null
+++ b/gui-wm/swayfx/swayfx-0.3.2.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson optfeature
+
+DESCRIPTION="SwayFX: Sway, but with eye candy!"
+HOMEPAGE="https://github.com/WillPower3309/swayfx"
+
+SRC_URI="https://github.com/WillPower3309/swayfx/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="grimshot +man +swaybar +swaynag tray wallpapers X"
+
+DEPEND="
+ >=dev-libs/json-c-0.13:0=
+ >=dev-libs/libinput-1.21.0:0=
+ sys-auth/seatd:=
+ dev-libs/libpcre
+ >=dev-libs/wayland-1.20.0
+ x11-libs/cairo
+ x11-libs/libxkbcommon
+ x11-libs/pango
+ x11-libs/pixman
+ media-libs/mesa[gles2,libglvnd(+)]
+ swaybar? ( x11-libs/gdk-pixbuf:2 )
+ tray? ( || (
+ sys-apps/systemd
+ sys-auth/elogind
+ sys-libs/basu
+ ) )
+ wallpapers? ( gui-apps/swaybg[gdk-pixbuf(+)] )
+ X? ( x11-libs/libxcb:0= )
+"
+DEPEND+="
+ >=gui-libs/wlroots-0.16:=[X?]
+ =dev-libs/wayland-protocols-1.24
+ >=dev-build/meson-0.60.0
+ virtual/pkgconfig
+"
+BDEPEND+="man? ( >=app-text/scdoc-1.9.3 )"
+REQUIRED_USE="tray? ( swaybar )"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature man man-pages)
+ $(meson_feature tray)
+ $(meson_feature X xwayland)
+ $(meson_feature swaybar gdk-pixbuf)
+ $(meson_use swaynag)
+ $(meson_use swaybar)
+ $(meson_use wallpapers default-wallpaper)
+ -Dfish-completions=true
+ -Dzsh-completions=true
+ -Dbash-completions=true
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ if use grimshot; then
+ doman contrib/grimshot.1
+ dobin contrib/grimshot
+ fi
+}
+
+pkg_postinst() {
+ optfeature_header "There are several packages that may be useful with swayfx:"
+ optfeature "wallpaper utility" gui-apps/swaybg
+ optfeature "idle management utility" gui-apps/swayidle
+ optfeature "simple screen locker" gui-apps/swaylock
+ optfeature "lightweight notification daemon" gui-apps/mako
+ echo
+ einfo "For a list of additional addons and tools usable with sway please"
+ einfo "visit the offical wiki at:"
+ einfo "https://github.com/swaywm/sway/wiki/Useful-add-ons-for-sway"
+ einfo "Please note that some of them might not (yet) available on gentoo"
+}